Gradle build in Eclipse Unsupported major.minor version 52.0

Get this error when building with Gradle in Eclipse Luna

The JRE is C:\Program Files (x86)\Java\jdk1.7.0_17